Topic: Ubuntu/Debian Packages

Package versions:
opensonic: 0.1.4-2 (2012-09-06)
opensonic-extra: 0.1.4~1 (2011-05-25)
allegro4.4: 2:4.4.2-2 (2012-09-06)
opensurge: 0.2.0~rev720-1 (2012-09-06)

Ubuntu - PPA Launchpad Repository
Supported architectures: i386, amd64
Supported systems: lucid, natty, oneiric, precise, quantal

https://launchpad.net/~szymonw/+archive/ppa

If you don't know how to install packages from Launchpad, read this:
https://help.launchpad.net/Packaging/PP … ngSoftware

Note: Finally I've finished native builds for oneiric and newer systems.  smile
Note 2: Since Allegro 4.4 appeared in Ubuntu Quantal official repositories, I modified opensurge_0.2.0~rev720-1quantal1 to use these official packages instead of mine. Unfortunately I wasn't able to do the same with old opensonic_0.1.4-2quantal1 because of the lack of Logg library in these official packages.

Debian
I recommend you to try Ubuntu Launchpad repositories - they should work fine on Debian system.

Here are some my packages created  during the testing on squeeze i386 and wheezy amd64
(opensurge_amd64 uses allegro4.4 from Debian official repository)

https://www.dropbox.com/sh/40uyfuvqnqg8fn7/WeRqOb2V14

To install Open Sonic from these packages take the following steps:
1. Create a new folder and download to it the following packages: opensonic, opensonic-data, liballeg4.4
2. Open the folder with these packages in a terminal and run the command (with root privileges):

dpkg -i *.deb

3. If you encounter some errors while installing the game, run after installation:

apt-get install -f

This will download the missing dependencies.

Sound and music
With the newest version of Allegro (4.4.2) sound and music should finally work "out of the box" on ubuntu and debian systems. If you still don't have sound with these packages:
1. Write to me about it!
2. Read this tutorial.

Bugs
Have you found a bug in packages? Or maybe you have encountered a problem? Write to me about it!

Last edited by SzynaW (2013-12-30 17:20:27)

Re: Ubuntu/Debian Packages

Oh, very nice!

Re: Ubuntu/Debian Packages

Thank you! The download area has been updated. smile

Re: Ubuntu/Debian Packages

great, even the new version of OpenSonic big_smile

http://ssdw.nl/forum/getforumpic.php

Re: Ubuntu/Debian Packages

Are there any packages for RPMs distros?

Re: Ubuntu/Debian Packages

CharlyTx wrote:

Are there any packages for RPMs distros?

are there any volunteers?

Re: Ubuntu/Debian Packages

what Linux are you using?

https://image.ibb.co/kuSYrm/SD_sml.pnghttps://image.ibb.co/kHq8P6/SeD_sml.pnghttps://image.ibb.co/cJf8P6/LTot_W_sml.png

Re: Ubuntu/Debian Packages

KZR wrote:

what Linux are you using?

Fedora 16 Verne x86 with Linux 3.3.1-1 and KDE 4.7.2

Re: Ubuntu/Debian Packages

KDE desktop... you might want to try installing LXDE then try to run the binaries. otherwise... you have to compile the source.

https://image.ibb.co/kuSYrm/SD_sml.pnghttps://image.ibb.co/kHq8P6/SeD_sml.pnghttps://image.ibb.co/cJf8P6/LTot_W_sml.png

Re: Ubuntu/Debian Packages

KZR wrote:

KDE desktop... you might want to try installing LXDE then try to run the binaries. otherwise... you have to compile the source.

Oh no! i wasn't saying I can't run the game, only I suggested a posibble new port of OpenSurge

Re: Ubuntu/Debian Packages

CharlyTx wrote:
KZR wrote:

KDE desktop... you might want to try installing LXDE then try to run the binaries. otherwise... you have to compile the source.

Oh no! i wasn't saying I can't run the game, only I suggested a posibble new port of OpenSurge

thanks, i have the same problem ... smile

Re: Ubuntu/Debian Packages

can you install gentoo 4 me

Yoshimitsu the Hedgehog

http://img17.imageshack.us/img17/518/4zcx.jpg

Re: Ubuntu/Debian Packages

Thanks for the info, really nice.